ClassNotFoundException FreeMarkerConfigurationFactory

Tengo una aplicación web grande que utiliza FreeMarker. Cuando actualicé recientemente a Spring 3.2.4 y ejecuté la aplicación web a través de jetty o tomcat, obtengo la siguiente excepción: java.lang.ClassNotFoundException: org.springframework.ui.freemarker.FreeMarkerConfigurationFactory.

Sé que Spring-webmvc tiene la clase FreeMarkerConfigurationFactory, así que tengo la dependencia incluida en mi POM. No sé por qué estoy recibiendo la excepción. He incluido mi POM y mi servlet de spring.

  4.0.0 WhiteSwan-Web com.millad.whiteswan.web 1.5 war    org.mortbay.jetty jetty-maven-plugin 8.1.12.v20130726     3.2.4.RELEASE 3.1.4.RELEASE 4.11 2.2 1.9.5 2.3.20    com.amazonaws aws-java-sdk 1.5.3   org.apache.logging.log4j log4j-api 2.0-beta8   org.apache.logging.log4j log4j-core 2.0-beta8   com.foursquare fongo 1.2.0   org.slf4j slf4j-api 1.7.5   org.aspectj aspectjrt 1.7.3   commons-codec commons-codec 1.8   org.mockito mockito-all ${mockito.version}   net.coobird thumbnailator 0.4.5    commons-io commons-io 1.3.2   commons-fileupload commons-fileupload 1.3    org.freemarker freemarker ${freemarker.version}   asm asm-commons 3.3.1   asm asm 20041228.180559   cglib cglib 2.2_beta1   junit junit ${junit.version} test   joda-time joda-time ${joda.time.version}   org.mongodb mongo-java-driver 2.11.2   org.codehaus.jackson jackson-core-asl 1.9.13   org.codehaus.jackson jackson-mapper-asl 1.9.13   org.springframework spring-core ${org.springframework.version}   org.springframework spring-context ${org.springframework.version}   org.springframework spring-test ${org.springframework.version} test   org.springframework.data spring-data-mongodb 1.2.3.RELEASE   javax.servlet javax.servlet-api 3.1.0   org.springframework spring-webmvc ${org.springframework.version}   org.springframework.security spring-security-web ${org.springframework.security.version}   org.springframework.security spring-security-core ${org.springframework.security.version}   org.springframework.security spring-security-config ${org.springframework.security.version}    

Mi servlet:

                    

Tuve que agregar el JAR de soporte de contexto de spring a mi proyecto para que funcione. Aquí está la entrada de Maven pom.xml:

  org.springframework spring-context-support 3.2.4.RELEASE