Error: los proyectos que contienen los descriptores de despliegue de la versión requieren enlaces en formato XMI o archivos de extensiones. ibm-web-bnd.xml

He actualizado el editor de Rad 7.5 a 8 y Maven 2 a 3 . Esto sucede justo después de importar proyectos de maven existentes en RAD 8, pero no tengo errores en ningún archivo pom.

El problema es con dos archivos xml:

Los proyectos que contienen descriptores de despliegue de versión requieren enlaces de formato XMI o archivos de extensiones. Mensaje de validación desconocido ibm-web-bnd.xml / DocViewerWeb / WebContent / WEB-INF

Los proyectos que contienen descriptores de despliegue de versión requieren enlaces de formato XMI o archivos de extensiones. Mensaje de validación desconocido ibm-web-ext.xml / DocViewerWeb / WebContent / WEB-INF

El contenido de esos dos archivos es:

          

y

          

Cual podría ser el problema aquí?

He publicado otro problema posiblemente relacionado : JSR250: CommonAnnotations for Java, 2.3: los métodos @Resource deben ser configuradores que siguen la convención estándar de JavaBeans

Los proyectos que contienen web.xml con version="2.4" o inferior requieren ibm-web-bnd. xmi y ibm-web-ext. xmi .

Los proyectos que contienen web.xml con version="2.5" o superior requieren ibm-web-bnd. xml y ibm-web-ext. xml .

¿Quizás el cambio en las versiones de la herramienta ha actualizado su versión web.xml a 2.5, y ahora RAD advierte que esto es incompatible con su web.xml?

Además del comentario sobre la respuesta de bkail (que es útil) si desea usar web.xml versión 2.5, debe usar el siguiente prólogo y el nodo principal. Técnicamente, el comentario es inexacto ya que faltan los espacios de nombres http: // y causarán errores adicionales si no usa esto:

   
    Intereting Posts