La ruta de la clase bootstrap no se estableció junto con -source 1.6 3

Recibí este error cuando estoy comstackndo el código:

[opciones] ruta de la clase bootstrap no establecida junto con -source 1.6

Sé que hay algunos temas al respecto, pero no lo entiendo, soy un principiante, por lo que es un poco complicado para mí. El progtwig es de mi escuela y estoy usando JDK 8 en casa, solo para que sepas.

Gracias

Está comstackndo para la compatibilidad con Java 6, pero utiliza Java 8 para hacerlo. Esto significa que podría usar nuevos métodos de API de Java 8 que no estarán disponibles si se ejecutan en versiones anteriores.

Puede comstackr sus clases para que solo funcionen en Java 8, o puede apuntar el comstackdor a una copia de las bibliotecas de Java 6 para que el comstackdor no vea ninguna de las nuevas API (y luego, si el progtwig comstack, debería trabajar en la versión anterior).

Ese mensaje es una advertencia y no un error. Si está absolutamente seguro de que no está utilizando Java 7 o métodos de API más nuevos, entonces puede ignorarse. En un proyecto más grande, es mucho más fácil dejar que el comstackdor haga el trabajo para estar absolutamente seguro, mediante el uso de la opción de línea de comandos javac mencionada en la advertencia.